You need to know John Deere’s mandatory software updates have consequences for all their models for the 2021 growing season.

John Deere needed to make updates to keep their software compatible with the satellite network. In order for your John Deere Ag Management Solutions satellite ran systems like AutoTrac and precision planting to stay functional, action is needed on your side. 

Every model of John Deere receivers now needs replacement or software updates:

John Deere iTC:  This older model of receiver is no longer supported by John Deere and will need to be replaced. The iTC receivers will no longer be able to receive correction signals required for machines to AutoTrac. 

What To Do:  There are currently no aftermarket solutions to create a workaround for this model. Upgrading the receiver with a newer model is the only option at this time. Unfortunately, inventory for newer receiver models are backlogged until June/July. Used StarFire models are available but they are being sold at much higher than usual prices. If you are in this position, please contact your PRM Risk Management Advisor for other options.  

StarFire 3000 and 6000:  Both the 3000 and 6000 models will need to have their software updated to the StarFire 20-2 Update. This update first became available in August 2020 and you may have already completed the update. If so, no more action is needed. All other growers will need to download the update to a flash drive from John Deere and install on their monitors. John Deere provides all the files and tutorials on their website.

Starfire 3000: 

Download the File Update

Download the Print Instructions

Watch the Tutorial Video

Starfire 6000: 

Download the File Update

Download the Print Instructions

Watch the Tutorial Video

Need help with the update? PRM’s Data Specialists can help!

PRM has a team of Data Specialists ready to help you with the software update. We are happy to set up a phone call to walk you through it or will come on-farm to do the update. We are here to help you however you need. 

Recent Posts

Start typing and press Enter to search